summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/go-examples/go-helloworld_0.1.bb')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
new file mode 100644
index 0000000000..d0de035921
--- /dev/null
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
+SECTION = "examples"
+HOMEPAGE = "https://golang.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "git://go.googlesource.com/example;branch=master;protocol=https"
+SRCREV = "2e68773dfca072cb81f219fc3b97ad34fe9d9f94"
+UPSTREAM_CHECK_COMMITS = "1"
+
+GO_IMPORT = "golang.org/x/example"
+GO_INSTALL = "${GO_IMPORT}/hello"
+
+export GO111MODULE="off"
+
+inherit go
+
+# This is just to make clear where this example is
+do_install:append() {
+ mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
+}