summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cracklib/cracklib_2.9.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cracklib/cracklib_2.9.8.bb')
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.8.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.8.bb b/meta/recipes-extended/cracklib/cracklib_2.9.8.bb
new file mode 100644
index 0000000000..786940a7e0
--- /dev/null
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.8.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Password strength checker library"
+HOMEPAGE = "https://github.com/cracklib/cracklib"
+DESCRIPTION = "${SUMMARY}"
+
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
+
+DEPENDS = "cracklib-native zlib"
+
+EXTRA_OECONF = "--without-python --libdir=${base_libdir}"
+
+SRC_URI = "git://github.com/cracklib/cracklib;protocol=https;branch=master \
+ file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \
+ file://0002-craklib-fix-testnum-and-teststr-failed.patch \
+ "
+
+SRCREV = "d9e8f9f47718539aeba80f90f4e072549926dc9c"
+S = "${WORKDIR}/git/src"
+
+inherit autotools gettext
+
+# This is custom stuff from upstream's autogen.sh
+do_configure:prepend() {
+ mkdir -p ${S}/m4
+ echo EXTRA_DIST = *.m4 > ${S}/m4/Makefile.am
+ touch ${S}/ABOUT-NLS
+}
+
+do_install:append:class-target() {
+ create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small
+}
+
+BBCLASSEXTEND = "native nativesdk"
+