aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at-3.1.12/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at-3.1.12/configure.patch')
-rw-r--r--meta/recipes-extended/at/at-3.1.12/configure.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at-3.1.12/configure.patch b/meta/recipes-extended/at/at-3.1.12/configure.patch
new file mode 100644
index 0000000000..2458ef357a
--- /dev/null
+++ b/meta/recipes-extended/at/at-3.1.12/configure.patch
@@ -0,0 +1,24 @@
+# Fix cross-compilation issues in configure.ac
+# Derived from an OE patch for at-3.1.8
+
+Index: at-3.1.12/configure.ac
+===================================================================
+--- at-3.1.12.orig/configure.ac
++++ at-3.1.12/configure.ac
+@@ -38,12 +38,11 @@ case "$host" in
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],