aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at-3.1.10.2/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at-3.1.10.2/configure.patch')
-rw-r--r--meta/recipes-extended/at/at-3.1.10.2/configure.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at-3.1.10.2/configure.patch b/meta/recipes-extended/at/at-3.1.10.2/configure.patch
new file mode 100644
index 0000000000..f6720111d6
--- /dev/null
+++ b/meta/recipes-extended/at/at-3.1.10.2/configure.patch
@@ -0,0 +1,22 @@
+# Fix cross-compilation issues in configure.ac
+# Derived from an OE patch for at-3.1.8
+
+--- at-3.1.10.2.orig/configure.in 2005-08-04 20:16:02.000000000 -0700
++++ at-3.1.10.2/configure.in 2010-07-21 15:52:38.000000000 -0700
+@@ -37,12 +37,11 @@
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],