summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/devel-config/distcc-config.bb25
-rw-r--r--meta/recipes-devtools/devel-config/distcc-config/distcc.sh4
-rw-r--r--meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb15
3 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/distcc-config.bb b/meta/recipes-devtools/devel-config/distcc-config.bb
new file mode 100644
index 0000000000..8deaa66589
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/distcc-config.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Sets up distcc for compilation on the target device"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://distcc.sh"
+
+S = "${WORKDIR}"
+
+# Default to the host machine for a running qemu session
+DISTCC_HOSTS ?= "192.168.7.1"
+
+do_configure() {
+ sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
+}
+
+RDEPENDS_${PN} = "distcc"
+
+inherit allarch
diff --git a/meta/recipes-devtools/devel-config/distcc-config/distcc.sh b/meta/recipes-devtools/devel-config/distcc-config/distcc.sh
new file mode 100644
index 0000000000..b4205931dc
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/distcc-config/distcc.sh
@@ -0,0 +1,4 @@
+DISTCC_HOSTS="@DISTCC_HOSTS@"
+#DISTCC_VERBOSE="1"
+
+export DISTCC_HOSTS
diff --git a/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb b/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb
new file mode 100644
index 0000000000..e55eed52e3
--- /dev/null
+++ b/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Provides a small set of tools for development on the device"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+RPROVIDES_${PN} = "qemu-config"
+RREPLACES_${PN} = "qemu-config"
+
+RDEPENDS_${PN} = "\
+ distcc-config \
+ oprofileui-server \
+ nfs-export-root \
+ bash \
+ "
+