aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch8
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.9.3.bb (renamed from meta/recipes-devtools/librepo/librepo_1.9.2.bb)4
2 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
index 488657154a..73902e5f58 100644
--- a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
+++ b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
@@ -1,4 +1,4 @@
-From 9f44d2f4aaf706027fe5a02f6d83547ff343f09c Mon Sep 17 00:00:00 2001
+From f5a1dfe4c87c228165bc25e7fe464120d8139a3d Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Fri, 30 Dec 2016 18:23:27 +0200
Subject: [PATCH] Set gpgme variables with pkg-config, not with cmake module
@@ -12,10 +12,10 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0f7271f..d71373f 100644
+index e949dbe..c954b2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -30,7 +30,8 @@ PKG_CHECK_MODULES(GLIB2 glib-2.0 REQUIRED)
+@@ -31,7 +31,8 @@ PKG_CHECK_MODULES(GLIB2 glib-2.0 REQUIRED)
PKG_SEARCH_MODULE(LIBCRYPTO REQUIRED libcrypto openssl)
PKG_CHECK_MODULES(LIBXML2 libxml-2.0 REQUIRED)
FIND_PACKAGE(CURL REQUIRED)
@@ -23,5 +23,5 @@ index 0f7271f..d71373f 100644
+PKG_CHECK_MODULES(GPGME gpgme REQUIRED)
+set(GPGME_VANILLA_LIBRARIES ${GPGME_LIBRARIES})
- INCLUDE_DIRECTORIES(${GLIB2_INCLUDE_DIRS})
+ IF (WITH_ZCHUNK)
diff --git a/meta/recipes-devtools/librepo/librepo_1.9.2.bb b/meta/recipes-devtools/librepo/librepo_1.9.3.bb
index 69c2411f7d..abfed798f3 100644
--- a/meta/recipes-devtools/librepo/librepo_1.9.2.bb
+++ b/meta/recipes-devtools/librepo/librepo_1.9.3.bb
@@ -7,7 +7,7 @@ SRC_URI = "git://github.com/rpm-software-management/librepo.git \
file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
"
-SRCREV = "313a7644d03f9657ee0c7aa747d1db260f8e2fc0"
+SRCREV = "f1212bd4a55467ab8578c87f98ed363cccd5907a"
S = "${WORKDIR}/git"
@@ -15,7 +15,7 @@ DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
inherit cmake distutils3-base pkgconfig
-EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DENABLE_TESTS=OFF -DENABLE_DOCS=OFF"
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DENABLE_TESTS=OFF -DENABLE_DOCS=OFF -DWITH_ZCHUNK=OFF"
BBCLASSEXTEND = "native nativesdk"