aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb1
-rw-r--r--meta/recipes-devtools/cve-check-tool/files/0001-Fix-freeing-memory-allocated-by-sqlite.patch50
2 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb b/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
index 1f906ee0a4..4829b118fe 100644
--- a/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
+++ b/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
@@ -11,6 +11,7 @@ SRC_URI = "https://github.com/ikeydoherty/${BPN}/releases/download/v${PV}/${BP}.
file://0001-print-progress-in-percent-when-downloading-CVE-db.patch \
file://0001-curl-allow-overriding-default-CA-certificate-file.patch \
file://0001-update-Compare-computed-vs-expected-sha256-digit-str.patch \
+ file://0001-Fix-freeing-memory-allocated-by-sqlite.patch \
"
SRC_URI[md5sum] = "c5f4247140fc9be3bf41491d31a34155"
diff --git a/meta/recipes-devtools/cve-check-tool/files/0001-Fix-freeing-memory-allocated-by-sqlite.patch b/meta/recipes-devtools/cve-check-tool/files/0001-Fix-freeing-memory-allocated-by-sqlite.patch
new file mode 100644
index 0000000000..4a82cf2dde
--- /dev/null
+++ b/meta/recipes-devtools/cve-check-tool/files/0001-Fix-freeing-memory-allocated-by-sqlite.patch
@@ -0,0 +1,50 @@
+From a3353429652f83bb8b0316500faa88fa2555542d Mon Sep 17 00:00:00 2001
+From: Peter Marko <peter.marko@siemens.com>
+Date: Thu, 13 Apr 2017 23:09:52 +0200
+Subject: [PATCH] Fix freeing memory allocated by sqlite
+
+Upstream-Status: Backport
+Signed-off-by: Peter Marko <peter.marko@siemens.com>
+---
+ src/core.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/core.c b/src/core.c
+index 6263031..6788f16 100644
+--- a/src/core.c
++++ b/src/core.c
+@@ -82,7 +82,7 @@ static bool ensure_table(CveDB *self)
+ rc = sqlite3_exec(self->db, query, NULL, NULL, &err);
+ if (rc != SQLITE_OK) {
+ fprintf(stderr, "ensure_table(): %s\n", err);
+- free(err);
++ sqlite3_free(err);
+ return false;
+ }
+
+@@ -91,7 +91,7 @@ static bool ensure_table(CveDB *self)
+ rc = sqlite3_exec(self->db, query, NULL, NULL, &err);
+ if (rc != SQLITE_OK) {
+ fprintf(stderr, "ensure_table(): %s\n", err);
+- free(err);
++ sqlite3_free(err);
+ return false;
+ }
+
+@@ -99,11 +99,11 @@ static bool ensure_table(CveDB *self)
+ rc = sqlite3_exec(self->db, query, NULL, NULL, &err);
+ if (rc != SQLITE_OK) {
+ fprintf(stderr, "ensure_table(): %s\n", err);
+- free(err);
++ sqlite3_free(err);
+ return false;
+ }
+ if (err) {
+- free(err);
++ sqlite3_free(err);
+ }
+
+ return true;
+--
+2.1.4
+