aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcf-agent
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcf-agent')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent/fix_tcf-agent.init.patch96
1 files changed, 0 insertions, 96 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_tcf-agent.init.patch b/meta/recipes-devtools/tcf-agent/tcf-agent/fix_tcf-agent.init.patch
deleted file mode 100644
index 8ea5b43d53..0000000000
--- a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_tcf-agent.init.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Upstream-Status: Inappropriate [poky-specific script]
-
---- a/Makefile
-+++ b/Makefile
-@@ -64,7 +64,7 @@
- install -d -m 755 $(INSTALLROOT)$(INCLUDE)/tcf/services
- install -c $(BINDIR)/agent -m 755 $(INSTALLROOT)$(SBIN)/tcf-agent
- install -c $(BINDIR)/client -m 755 $(INSTALLROOT)$(SBIN)/tcf-client
-- install -c main/tcf-agent.init -m 755 $(INSTALLROOT)$(INIT)/tcf-agent
-+ install -c tcf-agent.init -m 755 $(INSTALLROOT)$(INIT)/tcf-agent
- install -c config.h -m 755 $(INSTALLROOT)$(INCLUDE)/tcf/config.h
- install -c -t $(INSTALLROOT)$(INCLUDE)/tcf/framework -m 644 framework/*.h
- install -c -t $(INSTALLROOT)$(INCLUDE)/tcf/services -m 644 services/*.h
---- /dev/null
-+++ b/tcf-agent.init
-@@ -0,0 +1,80 @@
-+#!/bin/sh
-+### BEGIN INIT INFO
-+# Provides: tcf-agent
-+# Default-Start: 3 5
-+# Default-Stop: 0 1 2 6
-+# Short-Description: Target Communication Framework agent
-+### END INIT INFO
-+
-+DAEMON_PATH=/usr/sbin/tcf-agent
-+DAEMON_NAME=`basename $DAEMON_PATH`
-+
-+. /etc/init.d/functions
-+
-+test -x $DAEMON_PATH || exit 0
-+
-+PATH=/sbin:/usr/sbin:/bin:/usr/bin
-+export PATH
-+
-+RETVAL=0
-+
-+case "$1" in
-+ start)
-+ echo -n "Starting $DAEMON_NAME: "
-+ $DAEMON_PATH -d -L- -l0
-+ RETVAL=$?
-+ if [ $RETVAL -eq 0 ] ; then
-+ echo "OK"
-+ touch /var/lock/subsys/$DAEMON_NAME
-+ else
-+ echo "FAIL"
-+ fi
-+ ;;
-+
-+ stop)
-+ echo -n "Stopping $DAEMON_NAME: "
-+ count=0
-+ pid=$(/bin/pidof $DAEMON_PATH)
-+ while [ -n "`/bin/pidof $DAEMON_PATH`" -a $count -lt 10 ] ; do
-+ kill $pid > /dev/null 2>&1
-+ sleep 1
-+ RETVAL=$?
-+ if [ $RETVAL != 0 -o -n "`/bin/pidof $DAEMON_PATH`" ] ; then
-+ sleep 3
-+ fi
-+ count=`expr $count + 1`
-+ pid=$(/bin/pidof $DAEMON_PATH)
-+ done
-+ rm -f /var/lock/subsys/$DAEMON_NAME
-+ if [ -n "`/bin/pidof $DAEMON_PATH`" ] ; then
-+ echo "FAIL"
-+ else
-+ echo "OK"
-+ fi
-+ ;;
-+
-+ restart)
-+ $0 stop
-+ sleep 1
-+ $0 start
-+ ;;
-+
-+ status)
-+ if [ -n "`/bin/pidof $DAEMON_PATH`" ] ; then
-+ echo "$DAEMON_NAME is running"
-+ else
-+ echo "$DAEMON_NAME is not running"
-+ fi
-+ ;;
-+
-+ condrestart)
-+ [ -f /var/lock/subsys/$DAEMON_NAME ] && $0 restart
-+ ;;
-+
-+ *)
-+ echo "usage: $0 { start | stop | restart | condrestart | status }"
-+ ;;
-+esac
-+
-+exit $RETVAL
-+