aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcf-agent/tcf-agent_git.bb')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
new file mode 100644
index 0000000000..8ac8022918
--- /dev/null
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "Target Communication Framework"
+HOMEPAGE = "http://wiki.eclipse.org/TCF"
+BUGTRACKER = "https://bugs.eclipse.org/bugs/"
+
+LICENSE = "EPL-1.0 | EDL-1.0"
+LIC_FILES_CHKSUM = "file://../epl-v10.html;md5=7aa4215a330a0a4f6a1cbf8da1a0879f \
+ file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
+
+SRCREV = "4ef94ecb927a8912c3d79ce137182247786cff8f"
+PV = "0.4.0+git${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git;proto=git \
+ http://www.eclipse.org/legal/epl-v10.html;name=epl \
+ file://fix_ranlib.patch \
+ file://fix_tcf-agent.init.patch \
+ "
+
+SRC_URI[epl.md5sum] = "7aa4215a330a0a4f6a1cbf8da1a0879f"
+SRC_URI[epl.sha256sum] = "4fd64aeed340d62a64a8da4b371efe0f6d0d745f4d2dbefacba86c646d36bc72"
+
+DEPENDS = "util-linux openssl"
+RDEPENDS_${PN} = "bash"
+
+S = "${WORKDIR}/git"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "tcf-agent"
+INITSCRIPT_PARAMS = "start 999 3 5 . stop 20 0 1 2 6 ."
+
+# mangling needed for make
+MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
+MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
+
+EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
+
+# They don't build on ARM and we don't need them actually.
+CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+ -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
+ -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
+ -DSERVICE_Expressions=0"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install INSTALLROOT=${D}
+}
+