summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch b/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
index 5d704567c8..abd33babeb 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
@@ -1,14 +1,17 @@
-Upstream-Status: Inappropriate [poky-specific fix]
+Actually pass the arguments to RANLIB.
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+Index: agent/Makefile.inc
+===================================================================
--- a/Makefile.inc
+++ b/Makefile.inc
-@@ -57,6 +57,9 @@
- ifeq ($(NO_UUID),)
- LIBS += -luuid
+@@ -92,6 +92,7 @@ ifeq ($(OPSYS),GNU/Linux)
+ OPTS += -DUSE_uuid_generate=0
endif
-+ ifneq ($(RANLIB),)
-+ RANLIB += $@
-+ endif
+ OPTS += -DENABLE_arch_$(shell uname -m)
++ RANLIB += $@
endif
-
+
ifneq ($(OPSYS),Windows)