summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/subversion/subversion_1.5.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion_1.5.5.bb')
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.5.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.5.5.bb b/meta/recipes-devtools/subversion/subversion_1.5.5.bb
new file mode 100644
index 0000000000..8adac8a6fa
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion_1.5.5.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r6"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1 \
+ file://libtool2.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+acpaths = "-I build/ -I build/ac-macros/"
+
+do_configure_prepend () {
+ rm -f ${S}/libtool
+ rm -f ${S}/build/libtool.m4
+}