aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch')
-rw-r--r--meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
new file mode 100644
index 0000000000..f5556b23e3
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
@@ -0,0 +1,28 @@
+strace: Add ptest
+
+Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
+Upstream-Status: Pending
+
+--- old/tests/Makefile.am 2013-07-23 13:44:24.660481381 +0200
++++ new/tests/Makefile.am 2013-07-23 16:22:42.937654391 +0200
+@@ -9,3 +9,20 @@
+ EXTRA_DIST = init.sh $(TESTS)
+
+ CLEANFILES = check.log
++
++buildtest-TESTS: $(check_PROGRAMS) $(TESTS)
++
++install-ptest:
++ install $(BUILDDIR)/strace $(DESTDIR)
++ install "$(srcdir)/.."/strace-log-merge $(DESTDIR)
++ install -d $(DESTDIR)/$(TESTDIR)
++ cp $(BUILDDIR)/$(TESTDIR)/Makefile $(DESTDIR)/$(TESTDIR)
++ sed -i -e 's/^Makefile:/_Makefile:/' $(DESTDIR)/$(TESTDIR)/Makefile
++ for file in $(check_PROGRAMS); do \
++ install $(BUILDDIR)/$(TESTDIR)/$$file $(DESTDIR)/$(TESTDIR); \
++ done
++ for file in $(EXTRA_DIST); do \
++ install $(srcdir)/$$file $(DESTDIR)/$(TESTDIR); \
++ sed -i -e 's/$${srcdir=.}/./g' $(DESTDIR)/$(TESTDIR)/$$file; \
++ done
++ sed -i -e 's/$$srcdir/./g' $(DESTDIR)/$(TESTDIR)/net