aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.0.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.0.bb b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
new file mode 100644
index 0000000000..72c072dae5
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
@@ -0,0 +1,26 @@
+require rsync.inc
+
+
+SRC_URI += "file://acinclude.m4"
+
+SRC_URI[md5sum] = "3be148772a33224771a8d4d2a028b132"
+SRC_URI[sha256sum] = "81ca23f77fc9b957eb9845a6024f41af0ff0c619b7f38576887c63fa38e2394e"
+
+EXTRA_OECONF += "--disable-xattr-support --disable-acl-support"
+
+# rsync 3.0 uses configure.sh instead of configure, and
+# makefile checks the existence of configure.sh
+do_configure_prepend () {
+ rm -f ${S}/configure ${S}/configure.sh
+ cp -f ${WORKDIR}/acinclude.m4 ${S}/
+
+ # by default, if crosscompiling, rsync
+ # disables a number of capabilities, hardlinking
+ # symlinks and special files (ie devices)
+ export rsync_cv_can_hardlink_special=yes
+ export rsync_cv_can_hardlink_symlink=yes
+}
+
+do_configure_append () {
+ cp -f ${S}/configure ${S}/configure.sh
+}