aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm/rpmatch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm/rpmatch.patch')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpmatch.patch30
1 files changed, 11 insertions, 19 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpmatch.patch b/meta/recipes-devtools/rpm/rpm/rpmatch.patch
index 20d13aa08c..2ededdac4a 100644
--- a/meta/recipes-devtools/rpm/rpm/rpmatch.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpmatch.patch
@@ -1,5 +1,6 @@
-Add configure check for rpmatch() and
-creates a compatable macro if it is not provided by the C library.
+Create a compatable macro if rpmatch() is not provided by the C library.
+
+This uses an existing configure check.
This is needed for uclibc since it does not have the above function
implemented.
@@ -8,24 +9,15 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: rpm-5.4.14/configure.ac
-===================================================================
---- rpm-5.4.14.orig/configure.ac
-+++ rpm-5.4.14/configure.ac
-@@ -943,7 +943,7 @@ AC_CHECK_FUNCS([dnl
- ftok getaddrinfo getattrlist getcwd getdelim getline getmode getnameinfo dnl
- getpassphrase getxattr getwd iconv inet_aton lchflags lchmod lchown dnl
- lgetxattr lsetxattr lutimes madvise mempcpy mkdtemp mkstemp mtrace dnl
-- posix_fadvise posix_fallocate putenv realpath regcomp secure_getenv __secure_getenv dnl
-+ posix_fadvise posix_fallocate putenv realpath regcomp rpmatch secure_getenv __secure_getenv dnl
- setattrlist setenv setlocale setmode setxattr dnl
- sigaddset sigdelset sigemptyset sighold sigrelse sigpause dnl
- sigprocmask sigsuspend sigaction dnl
-Index: rpm-5.4.14/system.h
+Updated to rpm 5.4.15+.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: rpm/system.h
===================================================================
---- rpm-5.4.14.orig/system.h
-+++ rpm-5.4.14/system.h
-@@ -353,6 +353,14 @@ extern int _tolower(int) __THROW /*@*/;
+--- rpm.orig/system.h
++++ rpm/system.h
+@@ -358,6 +358,14 @@ extern int _tolower(int) __THROW /*@*/;
#include <libgen.h>
#endif