aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
new file mode 100644
index 0000000000..19fb6f4ff7
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Qemu helper utilities from Poky"
+LICENSE = "GPLv2"
+RDEPENDS = "qemu-native"
+PR = "r0"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-helper"
+
+SRC_URI = "file://tunctl.c"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_compile() {
+ ${CC} tunctl.c -o tunctl
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install tunctl ${D}${bindir}/
+}