aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch')
-rw-r--r--meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch b/meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch
new file mode 100644
index 0000000000..7b33aa4840
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-0.12.4/linker-flags.patch
@@ -0,0 +1,22 @@
+Fedora 13 switched the default behaviour of the linker to no longer
+indirectly link to required libraries (i.e. dependencies of a library
+already linked to). Therefore we need to explicitly pass the depended on
+libraries into the linker for building to work on Fedora 13.
+
+More information is available on the Fedora Wiki:
+https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
+
+JL - 15/06/10
+Index: qemu-0.12.4/Makefile.target
+===================================================================
+--- qemu-0.12.4.orig/Makefile.target 2010-06-15 11:21:52.000000000 +0100
++++ qemu-0.12.4/Makefile.target 2010-06-15 11:25:27.212852910 +0100
+@@ -178,7 +178,7 @@
+ obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
+ obj-$(CONFIG_KVM) += kvm.o kvm-all.o
+ obj-$(CONFIG_ISA_MMIO) += isa_mmio.o
+-LIBS+=-lz
++LIBS+=-lz -lX11 -ldl
+
+ sound-obj-y =
+ sound-obj-$(CONFIG_SB16) += sb16.o