summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.5.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index 72478f8663..2a4547694a 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -215,6 +215,8 @@ py_package_preprocess () {
mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}
}
+PACKAGES_remove = "${PN}"
+
# manual dependency additions
RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
@@ -249,8 +251,6 @@ RDEPENDS_${PN}-dev = ""
BBCLASSEXTEND = "nativesdk"
-RPROVIDES_${PN} += "${PN}-modules"
-
# We want bytecode precompiled .py files (.pyc's) by default
# but the user may set it on their own conf
INCLUDE_PYCS ?= "1"