summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb
new file mode 100644
index 0000000000..a8b2653ccd
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_1.1.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Sphinx Theme reader"
+HOMEPAGE = "https://github.com/readthedocs/sphinx_rtd_theme"
+SECTION = "devel/python"
+LICENSE = "MIT & OFL-1.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a1db7d4ef426c2935227264e1d4ae8f9 \
+ file://OFL-License.txt;md5=4534c22e0147eadb6828bd9fe86d4868 \
+ file://Apache-License-2.0.txt;md5=8a75796f0ef19c3f601d69857f5a9a5b"
+
+DEPENDS = "python3-sphinx"
+
+PYPI_PACKAGE = "sphinx_rtd_theme"
+
+SRC_URI[sha256sum] = "6146c845f1e1947b3c3dd4432c28998a1693ccc742b4f9ad7c63129f0757c103"
+UPSTREAM_CHECK_REGEX ?= "/sphinx-rtd-theme/(?P<pver>(\d+[\.\-_]*)+)/"
+
+inherit setuptools3 pypi
+
+#Fake out the setup scipt
+export CI = "True"
+export TOX_ENV_NAME = "True"
+
+BBCLASSEXTEND = "native nativesdk"