summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons-native_4.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons-native_4.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons-native_4.1.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons-native_4.1.0.bb b/meta/recipes-devtools/python/python3-scons-native_4.1.0.bb
new file mode 100644
index 0000000000..9e127304d6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-scons-native_4.1.0.bb
@@ -0,0 +1,7 @@
+require python3-scons_${PV}.bb
+inherit native python3native
+DEPENDS = "python3-native python3-setuptools-native"
+
+do_install_append() {
+ create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
+}