summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb b/meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb
new file mode 100644
index 0000000000..c3025fdc66
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyyaml_5.4.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python support for YAML"
+DEPENDS += "libyaml ${PYTHON_PN}-cython-native"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d8242660a8371add5fe547adf083079"
+
+PYPI_PACKAGE = "PyYAML"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "607774cbba28732bfa802b54baa7484215f530991055bb562efbed5b2f20a45e"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"