summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb b/meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb
new file mode 100644
index 0000000000..f7a2c1bb95
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest-runner_6.0.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+HOMEPAGE = "https://pypi.org/project/pytest-runner/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
+
+SRC_URI[sha256sum] = "b4d85362ed29b4c348678de797df438f0f0509497ddb8c647096c02a6d87b685"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io ${PYTHON_PN}-distutils"
+
+BBCLASSEXTEND = "native nativesdk"