summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-packaging_20.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-packaging_20.8.bb')
-rw-r--r--meta/recipes-devtools/python/python3-packaging_20.8.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-packaging_20.8.bb b/meta/recipes-devtools/python/python3-packaging_20.8.bb
new file mode 100644
index 0000000000..658c3d1f33
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-packaging_20.8.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[sha256sum] = "78598185a7008a470d64526a8059de9aaa449238f280fc9eb6b13ba6c4109093"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"