aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.6.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.6.bb b/meta/recipes-devtools/python/python3-native_3.5.6.bb
index 1e98c036c3..4c8faf88c0 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.6.bb
@@ -85,7 +85,11 @@ python(){
import json
pythondir = d.getVar('THISDIR',True)
with open(pythondir+'/python3/python3-manifest.json') as manifest_file:
- python_manifest=json.load(manifest_file)
+ manifest_str = manifest_file.read()
+ json_start = manifest_str.find('# EOC') + 6
+ manifest_file.seek(json_start)
+ manifest_str = manifest_file.read()
+ python_manifest = json.loads(manifest_str)
rprovides = d.getVar('RPROVIDES').split()