summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-markdown_3.3.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-markdown_3.3.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-markdown_3.3.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-markdown_3.3.7.bb b/meta/recipes-devtools/python/python3-markdown_3.3.7.bb
new file mode 100644
index 0000000000..c456cecc78
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-markdown_3.3.7.bb
@@ -0,0 +1,13 @@
+SUMMARY = "A Python implementation of John Gruber's Markdown."
+HOMEPAGE = "https://python-markdown.github.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=745aaad0c69c60039e638bff9ffc59ed"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "Markdown"
+SRC_URI[sha256sum] = "cbb516f16218e643d8e0a95b309f77eb118cb138d39a4f27851e6a63581db874"
+
+BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += "${PYTHON_PN}-logging ${PYTHON_PN}-setuptools"