summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-installer_0.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-installer_0.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-installer_0.5.1.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-installer_0.5.1.bb b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
index b7780702d6..07bbafa81f 100644
--- a/meta/recipes-devtools/python/python3-installer_0.5.1.bb
+++ b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
@@ -12,11 +12,15 @@ SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953d
inherit pypi python_flit_core
-# Bootstrap the native install by installing with ourself
-DEPENDS:remove:class-native = "python3-installer-native"
+# Bootstrap the native build
+DEPENDS:remove:class-native = "python3-picobuild-native python3-installer-native"
INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
+do_compile:class-native () {
+ python_flit_core_do_manual_build
+}
+
do_install:prepend:class-native() {
export PYTHONPATH="${S}/src"
}