summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hatchling_1.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-hatchling_1.12.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hatchling_1.12.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hatchling_1.12.2.bb b/meta/recipes-devtools/python/python3-hatchling_1.12.2.bb
new file mode 100644
index 0000000000..7f5a29879b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-hatchling_1.12.2.bb
@@ -0,0 +1,17 @@
+SUMMARY = "The extensible, standards compliant build backend used by Hatch"
+HOMEPAGE = "https://hatch.pypa.io/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
+
+inherit pypi python_hatchling
+
+DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native"
+DEPENDS:remove:class-native = "python3-hatchling-native"
+
+SRC_URI[sha256sum] = "8a6d719d96653a0f3901072b12710c9c3cc934f9061b443775c6789b45333495"
+
+do_compile:prepend() {
+ export PYTHONPATH=src
+}
+
+BBCLASSEXTEND = "native nativesdk"