summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb b/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
new file mode 100644
index 0000000000..6ce45ca6ee
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Modern password hashing for your software and your servers."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
+HOMEPAGE = "https://pypi.org/project/bcrypt/"
+
+DEPENDS += "${PYTHON_PN}-cffi-native"
+
+SRC_URI[sha256sum] = "27d375903ac8261cfe4047f6709d16f7d18d39b1ec92aaf72af989552a650ebd"
+
+inherit pypi python_setuptools3_rust ptest cargo-update-recipe-crates
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+require ${BPN}-crates.inc
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN}:class-target += "\
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+"