summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-attrs_22.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-attrs_22.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-attrs_22.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-attrs_22.2.0.bb b/meta/recipes-devtools/python/python3-attrs_22.2.0.bb
new file mode 100644
index 0000000000..20dccc6639
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-attrs_22.2.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Classes Without Boilerplate"
+HOMEPAGE = "http://www.attrs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
+
+SRC_URI[sha256sum] = "c9227bfc2f01993c03f68db37d1d15c9690188323c067c641f1a35ca58185f99"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN}:class-target += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
+RDEPENDS:${PN}:class-nativesdk += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
+
+BBCLASSEXTEND = "native nativesdk"