aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch')
-rw-r--r--meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch b/meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch
index 2b62db3826..e6d6c65bbe 100644
--- a/meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch
+++ b/meta/recipes-devtools/python/python/check-if-target-is-64b-not-host.patch
@@ -11,11 +11,11 @@ Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Upstream-Status: Pending
-Index: Python-2.7.2/setup.py
+Index: Python-2.7.11/setup.py
===================================================================
---- Python-2.7.2.orig/setup.py 2012-03-25 01:10:41.540163187 +0200
-+++ Python-2.7.2/setup.py 2012-03-25 01:26:06.092539990 +0200
-@@ -23,6 +23,21 @@
+--- Python-2.7.11.orig/setup.py
++++ Python-2.7.11/setup.py
+@@ -35,6 +35,21 @@ COMPILED_WITH_PYDEBUG = ('--with-pydebug
# This global variable is used to hold the list of modules to be disabled.
disabled_module_list = []
@@ -37,16 +37,16 @@ Index: Python-2.7.2/setup.py
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
1) 'dir' is not already in 'dirlist'
-@@ -628,7 +643,7 @@
+@@ -716,7 +731,7 @@ class PyBuildExt(build_ext):
exts.append( Extension('audioop', ['audioop.c']) )
# Disabled on 64-bit platforms
-- if sys.maxint != 9223372036854775807L:
+- if sys.maxsize != 9223372036854775807L:
+ if not target_is_64bit_platform():
# Operations on images
exts.append( Extension('imageop', ['imageop.c']) )
else:
-@@ -1418,7 +1433,7 @@
+@@ -1545,7 +1560,7 @@ class PyBuildExt(build_ext):
missing.append('_codecs_%s' % loc)
# Dynamic loading module
@@ -54,4 +54,4 @@ Index: Python-2.7.2/setup.py
+ if not target_is_64bit_platform():
# This requires sizeof(int) == sizeof(long) == sizeof(char*)
dl_inc = find_file('dlfcn.h', [], inc_dirs)
- if (dl_inc is not None) and (platform not in ['atheos']):
+ if (dl_inc is not None) and (host_platform not in ['atheos']):