aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-mako_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-mako_1.0.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-mako_1.0.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-mako_1.0.6.bb b/meta/recipes-devtools/python/python-mako_1.0.6.bb
new file mode 100644
index 0000000000..230044e1a2
--- /dev/null
+++ b/meta/recipes-devtools/python/python-mako_1.0.6.bb
@@ -0,0 +1,17 @@
+require python-mako.inc
+
+inherit setuptools
+
+RDEPENDS_${PN} = "python-threading \
+ python-netclient \
+ python-html \
+"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"
+
+# The same utility is packaged in python3-mako, so it would conflict
+do_install_append() {
+ rm -f ${D}${bindir}/mako-render
+ rmdir ${D}${bindir}
+}