aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-gst_0.10.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-gst_0.10.18.bb')
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.18.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gst_0.10.18.bb b/meta/recipes-devtools/python/python-gst_0.10.18.bb
new file mode 100644
index 0000000000..9de07b3c4f
--- /dev/null
+++ b/meta/recipes-devtools/python/python-gst_0.10.18.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python Gstreamer bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "gstreamer gst-plugins-base python-pygobject"
+PR = "ml1"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
+ file://python-path.patch"
+S = "${WORKDIR}/gst-python-${PV}"
+
+inherit autotools distutils-base pkgconfig
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+FILES_${PN} += "${datadir}/gst-python"
+FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/"