summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-gitdb_0.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-gitdb_0.6.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-gitdb_0.6.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gitdb_0.6.1.bb b/meta/recipes-devtools/python/python-gitdb_0.6.1.bb
new file mode 100644
index 0000000000..ead93e1e7d
--- /dev/null
+++ b/meta/recipes-devtools/python/python-gitdb_0.6.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A pure-Python git object database"
+HOMEPAGE = "http://github.com/gitpython-developers/gitdb"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
+DEPENDS = "python-async python-smmap"
+
+SRC_URI = "https://pypi.python.org/packages/source/g/gitdb/gitdb-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "daeb85a5e97d2d100fd37cf522fd65d5"
+SRC_URI[sha256sum] = "0d784ec4a75e93c8f65d4aca219c17e388a052d461714ed0edfda657e542b716"
+
+S = "${WORKDIR}/gitdb-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} += "python-smmap python-async python-mmap python-lang python-zlib python-io python-shell"
+
+BBCLASSEXTEND = "nativesdk"