aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pseudo')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch20
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb3
2 files changed, 1 insertions, 22 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
deleted file mode 100644
index a73ed64804..0000000000
--- a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-The cached data values were being collected when an OP_EXEC call was made.
-This is incorrect as the values are only for logging purposes. It's believed
-this caused an occasional crash in certain instances.
-
-Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-
-diff --git a/pseudo.c b/pseudo.c
-index efee436..62f28f3 100644
---- a/pseudo.c
-+++ b/pseudo.c
-@@ -1021,7 +1021,8 @@ pseudo_op(pseudo_msg_t *msg, const char *program, const char *tag) {
- if (msg->op != OP_MAY_UNLINK &&
- msg->op != OP_DID_UNLINK &&
- msg->op != OP_CANCEL_UNLINK &&
-- msg->op != OP_UNLINK) {
-+ msg->op != OP_UNLINK &&
-+ msg->op != OP_EXEC ) {
- cache_msg = *msg;
-
- if (path_by_ino) {
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 6645033c3e..4e94df7e8c 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -6,11 +6,10 @@ LICENSE = "LGPL2.1"
DEPENDS = "sqlite3"
PV = "0.0+git${SRCPV}"
-PR = "r16"
+PR = "r17"
SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
file://static_sqlite.patch \
- file://pseudo-exec-crash.patch \
"
FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"