summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.32.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.32.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.1.bb b/meta/recipes-devtools/perl/perl_5.32.1.bb
index 1fafc0a8c9..65db6da2b5 100644
--- a/meta/recipes-devtools/perl/perl_5.32.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.1.bb
@@ -320,6 +320,9 @@ python split_perl_packages () {
# Read the pre-generated dependency file, and use it to set module dependecies
for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines():
splitline = line.split()
+ # Filter empty lines and comments
+ if len(splitline) == 0 or splitline[0].startswith("#"):
+ continue
if bb.data.inherits_class('native', d):
module = splitline[0] + '-native'
depends = "perl-native"