summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ninja/ninja_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.11.1.bb')
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.11.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.11.1.bb b/meta/recipes-devtools/ninja/ninja_1.11.1.bb
new file mode 100644
index 0000000000..255f5efb70
--- /dev/null
+++ b/meta/recipes-devtools/ninja/ninja_1.11.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Ninja is a small build system with a focus on speed."
+HOMEPAGE = "https://ninja-build.org/"
+DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+DEPENDS = "re2c-native ninja-native"
+
+SRCREV = "a524bf3f6bacd1b4ad85d719eed2737d8562f27a"
+
+SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release;protocol=https"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile:class-native() {
+ python3 ./configure.py --bootstrap
+}
+
+do_compile() {
+ python3 ./configure.py
+ ninja
+}
+
+do_install() {
+ install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}
+
+BBCLASSEXTEND = "native nativesdk"