summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ninja/ninja_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.10.0.bb')
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.10.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.10.0.bb b/meta/recipes-devtools/ninja/ninja_1.10.0.bb
new file mode 100644
index 0000000000..bdc6365052
--- /dev/null
+++ b/meta/recipes-devtools/ninja/ninja_1.10.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Ninja is a small build system with a focus on speed."
+HOMEPAGE = "http://martine.github.com/ninja/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+DEPENDS = "re2c-native ninja-native"
+
+SRCREV = "ed7f67040b370189d989adbd60ff8ea29957231f"
+
+SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile_class-native() {
+ python3 ./configure.py --bootstrap
+}
+
+do_compile() {
+ python3 ./configure.py
+ ninja
+}
+
+do_install() {
+ install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}
+
+BBCLASSEXTEND = "native nativesdk"