aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/meson/meson_0.45.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/meson/meson_0.45.1.bb')
-rw-r--r--meta/recipes-devtools/meson/meson_0.45.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/meson_0.45.1.bb b/meta/recipes-devtools/meson/meson_0.45.1.bb
new file mode 100644
index 0000000000..9decdd0c24
--- /dev/null
+++ b/meta/recipes-devtools/meson/meson_0.45.1.bb
@@ -0,0 +1,21 @@
+HOMEPAGE = "http://mesonbuild.com"
+SUMMARY = "A high performance build system"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "https://github.com/mesonbuild/meson/releases/download/${PV}/${BP}.tar.gz \
+ file://0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch \
+ file://0002-gobject-introspection-determine-g-ir-scanner-and-g-i.patch \
+ file://0001-Linker-rules-move-cross_args-in-front-of-output_args.patch \
+ file://0003-native_bindir.patch \
+ "
+SRC_URI[md5sum] = "4d9c7b3a7365b7b472f00af14e034949"
+SRC_URI[sha256sum] = "4d0bb0dbb1bb556cb7a4092fdfea3d6e76606bd739a4bc97481c2d7bc6200afb"
+UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "ninja python3-core python3-modules"
+
+BBCLASSEXTEND = "native"