aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 722bc53aa1..f36e6978ed 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -42,8 +42,7 @@ def get_llvm_arch(bb, d, arch_var):
elif re.match('mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips'
elif re.match('p(pc|owerpc)(|64)', a): return 'PowerPC'
else:
- bb.error("cannot map '%s' to a supported llvm architecture" % a)
- return ""
+ raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a)
def get_llvm_target_arch(bb, d):
return get_llvm_arch(bb, d, 'TARGET_ARCH')