summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-runtime_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-runtime_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-runtime_1.9.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-devtools/go/go-runtime_1.9.bb b/meta/recipes-devtools/go/go-runtime_1.9.bb
deleted file mode 100644
index d5279ea897..0000000000
--- a/meta/recipes-devtools/go/go-runtime_1.9.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-require go-${PV}.inc
-require go-runtime.inc
-
-export GO_TARGET_INSTALL = "std"
-export CC_FOR_TARGET = "${CC}"
-export CXX_FOR_TARGET = "${CXX}"
-
-do_compile() {
- export GOBIN="${B}/bin"
- export TMPDIR="$GOTMPDIR"
- export CC=$BUILD_CC
-
- cd src
- CGO_CFLAGS="${BUILD_CFLAGS}" CGO_LDFLAGS="${BUILD_LDFLAGS}" ./make.bash --host-only
- cp ${B}/pkg/tool/${BUILD_GOTUPLE}/go_bootstrap ${B}
- rm -rf ${B}/pkg/${TARGET_GOTUPLE}
- ./make.bash --target-only
- if [ -n "${GO_DYNLINK}" ]; then
- cp ${B}/go_bootstrap ${B}/pkg/tool/${BUILD_GOTUPLE}
- GO_FLAGS="-buildmode=shared" GO_LDFLAGS="-extldflags \"${LDFLAGS}\"" ./make.bash --target-only
- fi
- cd ${B}
-}