aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dpkg')
-rwxr-xr-xmeta/recipes-devtools/dpkg/run-postinsts/run-postinsts36
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk30
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts_1.0.bb29
3 files changed, 0 insertions, 95 deletions
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
deleted file mode 100755
index 5f6442cbe3..0000000000
--- a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-#
-# Copyright 2007 Openedhand Ltd.
-#
-# Author: Richard Purdie <rpurdie@openedhand.com>
-#
-
-PKGSYSTEM=/var/lib/dpkg
-
-if [ ! -e $PKGSYSTEM/status ]; then
- if [ -e /var/lib/opkg/status ]; then
- PKGSYSTEM=/var/lib/opkg
- else
- echo "No package system found"
- exit 1
- fi
-fi
-
-STAMP=$PKGSYSTEM/postinsts-done
-STATFILE=$PKGSYSTEM/status
-STATFILE2=$PKGSYSTEM/status2
-
-if [ -e $STAMP ]; then
- exit 0
-fi
-
-awk -f /usr/share/run-postinsts/run-postinsts.awk $STATFILE > $STATFILE2
-if [ $? = 0 ]; then
- mv $STATFILE2 $STATFILE
- touch $STAMP
- exit 0
-else
- rm -f $STATFILE2
- rm -f $STAMP
- exit 1
-fi
diff --git a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk b/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
deleted file mode 100644
index cbc8d1a109..0000000000
--- a/meta/recipes-devtools/dpkg/run-postinsts/run-postinsts.awk
+++ /dev/null
@@ -1,30 +0,0 @@
-#
-# Copyright 2007 Openedhand Ltd.
-#
-# Author: Richard Purdie <rpurdie@openedhand.com>
-#
-# Rather hacky proof of concept
-#
-
-BEGIN {
- rc=system("test -d /var/lib/dpkg/info/")
- if (rc==0)
- pkgdir="/var/lib/dpkg/info"
- else
- pkgdir="/var/lib/opkg/info"
- package=""
-}
-/Package:.*/ {
- package = substr($0, 10)
-}
-/Status:.*unpacked.*/ {
- print "Configuring: " package > "/dev/stderr"
- ret = system(pkgdir "/" package ".postinst 1>&2")
- if (ret == 0)
- $0 = gensub("unpacked", "installed", 1)
- else
- print "Postinstall failed for " package > "/dev/stderr"
-}
-{
- print $0
-}
diff --git a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
deleted file mode 100644
index 4c9b2fd75a..0000000000
--- a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Run postinstall scripts on device using awk"
-SECTION = "devel"
-PR = "r9"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "file://run-postinsts file://run-postinsts.awk"
-
-INITSCRIPT_NAME = "run-postinsts"
-INITSCRIPT_PARAMS = "start 98 S ."
-
-inherit update-rc.d
-
-do_configure() {
- :
-}
-
-do_compile () {
- :
-}
-
-do_install() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
-
- install -d ${D}${datadir}/${BPN}/
- install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${BPN}/
-}