aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch')
-rw-r--r--meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch b/meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch
new file mode 100644
index 0000000000..e82319f36d
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf/0004-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch
@@ -0,0 +1,13 @@
+Index: dnf/CMakeLists.txt
+===================================================================
+--- dnf.orig/CMakeLists.txt
++++ dnf/CMakeLists.txt
+@@ -19,7 +19,7 @@ ELSE ()
+ MESSAGE (FATAL_ERROR "Invalid PYTHON_DESIRED value: " ${PYTHON_DESIRED})
+ ENDIF()
+
+-EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib())" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
++#EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib())" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
+ MESSAGE(STATUS "Python install dir is ${PYTHON_INSTALL_DIR}")
+
+ ADD_SUBDIRECTORY (dnf)