summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.65.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.65.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.65.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.65.bb b/meta/recipes-devtools/diffstat/diffstat_1.65.bb
new file mode 100644
index 0000000000..59db7b1d78
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.65.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Tool to produce a statistics based on a diff"
+DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
+the insertions, deletions, and modifications per-file. It is useful for \
+reviewing large, complex patch files."
+HOMEPAGE = "http://invisible-island.net/diffstat/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6450594049f0eed1052e634ddcbeec28"
+
+SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
+ file://run-ptest \
+ file://avoid-check-user-break-cc.patch \
+ "
+
+SRC_URI[sha256sum] = "8cf27424926debcd85921755c3915559288244bd103f62d740dc6b83b557a28a"
+
+inherit autotools gettext ptest
+
+EXTRA_AUTORECONF += "--exclude=aclocal"
+
+LDFLAGS += "${TOOLCHAIN_OPTIONS}"
+
+do_install_ptest() {
+ cp -r ${S}/testing ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND = "nativesdk"