aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bootchart2/bootchart2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bootchart2/bootchart2_git.bb')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_git.bb b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
index 04fb901b68..5fc7211f79 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_git.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
@@ -120,6 +120,12 @@ do_compile_append_class-native () {
chmod +x ${S}/pybootchartgui
}
+do_compile_prepend () {
+ export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
+ export BINDIR="${bindir}"
+ export LIBDIR="${base_libdir}"
+}
+
do_install () {
install -d ${D}${sysconfdir} # needed for -native
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"