summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch')
-rw-r--r--meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch b/meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch
new file mode 100644
index 0000000000..850ec06aa7
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison/fix_cross_manpage_building.patch
@@ -0,0 +1,18 @@
+help2man is looking at the generated binary for help output. This does not work for cross compilations. So taking out the local PREPATH (../src) directory from path so that help2 man can find the native version of the bison in the native sysroot directory.
+
+Date: 2010/06/28
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Index: bison-2.4.2/doc/Makefile.am
+===================================================================
+--- bison-2.4.2.orig/doc/Makefile.am
++++ bison-2.4.2/doc/Makefile.am
+@@ -77,7 +77,7 @@ PREPATH = $(top_builddir)/src
+ (cd $$dir && $(MAKE) $(AM_MAKEFLAGS) $$program) || exit; \
+ done
+ @echo "Updating man page $@"
+- PATH="$(PREPATH)$(PATH_SEPARATOR)$$PATH"; \
++# PATH="$(PREPATH)$(PATH_SEPARATOR)$$PATH";
+ export PATH; \
+ $(HELP2MAN) \
+ --include=$*.x \