aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt-0.7.14
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/apt/apt-0.7.14')
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/allocate-larger-memory.patch75
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/includes-fix.patch44
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/localefixes.patch91
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/makerace.patch23
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/no-ko-translation.patch11
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/noconfigure.patch37
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/nodoc.patch21
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/remove-redeclaration.patch63
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/truncate-filename.patch35
-rw-r--r--meta/recipes-devtools/apt/apt-0.7.14/use-host.patch42
10 files changed, 0 insertions, 442 deletions
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/allocate-larger-memory.patch b/meta/recipes-devtools/apt/apt-0.7.14/allocate-larger-memory.patch
deleted file mode 100644
index 36e1499005..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/allocate-larger-memory.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Method file has died unexpectedly
-
-"Method file has died unexpectedly!", this is because the "char S[1024]"
-is not enough for the long the URI, "char S[2048]" would be enough.
-
-It would be boring if we use malloc here since we can't know how much
-memory is needed except strelen() every component of it. So similarly
-use "char S[2048]" as it did before.
-
-Upstream-Status: Pending
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- apt-pkg/acquire-method.cc | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/apt-pkg/acquire-method.cc b/apt-pkg/acquire-method.cc
---- a/apt-pkg/acquire-method.cc
-+++ b/apt-pkg/acquire-method.cc
-@@ -95,7 +95,7 @@ void pkgAcqMethod::Fail(string Err,bool Transient)
- *I = ' ';
- }
-
-- char S[1024];
-+ char S[2048];
- if (Queue != 0)
- {
- snprintf(S,sizeof(S)-50,"400 URI Failure\nURI: %s\n"
-@@ -132,7 +132,7 @@ void pkgAcqMethod::URIStart(FetchResult &Res)
- if (Queue == 0)
- abort();
-
-- char S[1024] = "";
-+ char S[2048] = "";
- char *End = S;
-
- End += snprintf(S,sizeof(S),"200 URI Start\nURI: %s\n",Queue->Uri.c_str());
-@@ -160,7 +160,7 @@ void pkgAcqMethod::URIDone(FetchResult &Res, FetchResult *Alt)
- if (Queue == 0)
- abort();
-
-- char S[1024] = "";
-+ char S[2048] = "";
- char *End = S;
-
- End += snprintf(S,sizeof(S),"201 URI Done\nURI: %s\n",Queue->Uri.c_str());
-@@ -242,7 +242,7 @@ void pkgAcqMethod::URIDone(FetchResult &Res, FetchResult *Alt)
- to be ackd */
- bool pkgAcqMethod::MediaFail(string Required,string Drive)
- {
-- char S[1024];
-+ char S[2048];
- snprintf(S,sizeof(S),"403 Media Failure\nMedia: %s\nDrive: %s\n\n",
- Required.c_str(),Drive.c_str());
-
-@@ -411,7 +411,7 @@ void pkgAcqMethod::Log(const char *Format,...)
- va_start(args,Format);
-
- // sprintf the description
-- char S[1024];
-+ char S[2048];
- unsigned int Len = snprintf(S,sizeof(S)-4,"101 Log\nURI: %s\n"
- "Message: ",CurrentURI.c_str());
-
-@@ -435,7 +435,7 @@ void pkgAcqMethod::Status(const char *Format,...)
- va_start(args,Format);
-
- // sprintf the description
-- char S[1024];
-+ char S[2048];
- unsigned int Len = snprintf(S,sizeof(S)-4,"102 Status\nURI: %s\n"
- "Message: ",CurrentURI.c_str());
-
---
-1.7.10.4
-
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/includes-fix.patch b/meta/recipes-devtools/apt/apt-0.7.14/includes-fix.patch
deleted file mode 100644
index c85c3881aa..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/includes-fix.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Upstream-Status: Backport
-
-Add missing includes required when building with modern toolchain, based on
-patch from Debian bugzilla:
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505954
-
-Should no longer be required once upgraded to 0.7.22 or later.
-
-Index: apt-0.7.14/apt-pkg/acquire.cc
-===================================================================
---- apt-0.7.14.orig/apt-pkg/acquire.cc 2008-05-28 14:22:13.000000000 +0100
-+++ apt-0.7.14/apt-pkg/acquire.cc 2010-07-23 17:30:11.494883936 +0100
-@@ -22,6 +22,7 @@
-
- #include <apti18n.h>
-
-+#include <cstdio>
- #include <iostream>
- #include <sstream>
-
-Index: apt-0.7.14/apt-pkg/contrib/sha256.h
-===================================================================
---- apt-0.7.14.orig/apt-pkg/contrib/sha256.h 2008-05-28 14:22:14.000000000 +0100
-+++ apt-0.7.14/apt-pkg/contrib/sha256.h 2010-07-23 17:30:11.494883936 +0100
-@@ -14,6 +14,7 @@
- #ifndef APTPKG_SHA256_H
- #define APTPKG_SHA256_H
-
-+#include <stdint.h>
- #include <string>
- #include <cstring>
- #include <algorithm>
-Index: apt-0.7.14/apt-pkg/deb/dpkgpm.cc
-===================================================================
---- apt-0.7.14.orig/apt-pkg/deb/dpkgpm.cc 2008-05-28 14:22:14.000000000 +0100
-+++ apt-0.7.14/apt-pkg/deb/dpkgpm.cc 2010-07-23 17:30:36.960856870 +0100
-@@ -20,6 +20,7 @@
- #include <stdlib.h>
- #include <fcntl.h>
- #include <sys/select.h>
-+#include <sys/stat.h>
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <signal.h>
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/localefixes.patch b/meta/recipes-devtools/apt/apt-0.7.14/localefixes.patch
deleted file mode 100644
index 80252732e2..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/localefixes.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Add in missing header includes to resolve compile failures with recent
-compiler/glibc combinations.
-
-Upstream-Status: Inappropriate [Resolved upstream]
-
-RP 2011/11/23
-
-Index: apt-0.7.14/apt-pkg/init.cc
-===================================================================
---- apt-0.7.14.orig/apt-pkg/init.cc 2011-11-23 22:48:53.544637868 +0000
-+++ apt-0.7.14/apt-pkg/init.cc 2011-11-23 22:48:59.456638260 +0000
-@@ -16,6 +16,7 @@
- #include <config.h>
- #include <cstdlib>
- #include <sys/stat.h>
-+#include <locale>
- /*}}}*/
-
- #define Stringfy_(x) # x
-Index: apt-0.7.14/cmdline/apt-cache.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-cache.cc 2011-11-23 22:53:29.048631067 +0000
-+++ apt-0.7.14/cmdline/apt-cache.cc 2011-11-23 22:54:15.784616212 +0000
-@@ -32,6 +32,7 @@
- #include <apti18n.h>
-
- #include <locale.h>
-+#include <locale>
- #include <iostream>
- #include <unistd.h>
- #include <errno.h>
-Index: apt-0.7.14/cmdline/apt-cdrom.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-cdrom.cc 2011-11-23 22:53:29.064631096 +0000
-+++ apt-0.7.14/cmdline/apt-cdrom.cc 2011-11-23 22:53:57.616630261 +0000
-@@ -27,6 +27,7 @@
- //#include "indexcopy.h"
-
- #include <locale.h>
-+#include <locale>
- #include <iostream>
- #include <fstream>
- #include <vector>
-Index: apt-0.7.14/cmdline/apt-config.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-config.cc 2011-11-23 22:50:16.796635352 +0000
-+++ apt-0.7.14/cmdline/apt-config.cc 2011-11-23 22:50:25.640633906 +0000
-@@ -27,6 +27,7 @@
- #include <locale.h>
- #include <iostream>
- #include <string>
-+#include <locale>
- /*}}}*/
- using namespace std;
-
-Index: apt-0.7.14/cmdline/apt-extracttemplates.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-extracttemplates.cc 2011-11-23 22:53:29.080631084 +0000
-+++ apt-0.7.14/cmdline/apt-extracttemplates.cc 2011-11-23 22:53:38.304630439 +0000
-@@ -39,6 +39,7 @@
- #include <config.h>
- #include <apti18n.h>
- #include "apt-extracttemplates.h"
-+#include <locale>
- /*}}}*/
-
- using namespace std;
-Index: apt-0.7.14/cmdline/apt-get.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-get.cc 2011-11-23 22:53:29.096631090 +0000
-+++ apt-0.7.14/cmdline/apt-get.cc 2011-11-23 22:53:49.368629452 +0000
-@@ -48,6 +48,7 @@
-
- #include <set>
- #include <locale.h>
-+#include <locale>
- #include <langinfo.h>
- #include <fstream>
- #include <termios.h>
-Index: apt-0.7.14/cmdline/apt-sortpkgs.cc
-===================================================================
---- apt-0.7.14.orig/cmdline/apt-sortpkgs.cc 2011-11-23 22:52:03.872640247 +0000
-+++ apt-0.7.14/cmdline/apt-sortpkgs.cc 2011-11-23 22:52:10.880638611 +0000
-@@ -27,6 +27,7 @@
-
- #include <locale.h>
- #include <unistd.h>
-+#include <locale>
- /*}}}*/
-
- using namespace std;
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/makerace.patch b/meta/recipes-devtools/apt/apt-0.7.14/makerace.patch
deleted file mode 100644
index 403711f013..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/makerace.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-I was seeing various issues with parallel make, mainly due to to what was likely
-partially installed headers. If you change into the source directory and
-"NOISY=1 make ../obj/apt-pkg/sourcelist.opic" in apt-pkg, you'll see it
-doesn't have any dependencies on the headers being installed. This patch
-fixes that so things build correctly.
-
-RP 2012/3/19
-
-Upstream-Status: Pending
-
-Index: apt-0.7.14/buildlib/library.mak
-===================================================================
---- apt-0.7.14.orig/buildlib/library.mak
-+++ apt-0.7.14/buildlib/library.mak
-@@ -61,7 +61,7 @@ $(LIB)/lib$(LIBRARY)$(LIBEXT).so.$(MAJOR
-
- # Compilation rules
- vpath %.cc $(SUBDIRS)
--$(OBJ)/%.opic: %.cc
-+$(OBJ)/%.opic: %.cc $($(LOCAL)-HEADERS)
- echo Compiling $< to $@
- $(CXX) -c $(INLINEDEPFLAG) $(CPPFLAGS) $(CXXFLAGS) $(PICFLAGS) -o $@ $<
- $(DoDep)
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/no-ko-translation.patch b/meta/recipes-devtools/apt/apt-0.7.14/no-ko-translation.patch
deleted file mode 100644
index 7fd1db8b25..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/no-ko-translation.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
----
- po/LINGUAS | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- apt-0.7.14.orig/po/LINGUAS
-+++ apt-0.7.14/po/LINGUAS
-@@ -1 +1 @@
--ar bg bs ca cs cy da de dz el en_GB es eu fi fr gl he hu it ja km ko ku mr nb ne nl nn pl pt pt_BR ro ru sk sl sv th tl uk vi zh_CN zh_TW
-+ar bg bs ca cs cy da de dz el en_GB es eu fi fr gl he hu it ja km ku mr nb ne nl nn pl pt pt_BR ro ru sk sl sv th tl uk vi zh_CN zh_TW
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/noconfigure.patch b/meta/recipes-devtools/apt/apt-0.7.14/noconfigure.patch
deleted file mode 100644
index 04e721d659..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/noconfigure.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
----
- apt-pkg/packagemanager.cc | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
-+++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
-@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
-
- List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
-
-+#if 0
- // Perform immedate configuration of the package.
- if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
- if (SmartConfigure(Pkg) == false)
- return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
-+#endif
-
- return true;
- }
-@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
- DoneSomething = true;
- }
-
-+#if 0
- // Final run through the configure phase
- if (ConfigureAll() == false)
- return Failed;
-@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
- return Failed;
- }
- }
-+#endif
-
- return Completed;
- }
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/nodoc.patch b/meta/recipes-devtools/apt/apt-0.7.14/nodoc.patch
deleted file mode 100644
index 216c091819..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/nodoc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- apt-0.7.14.orig/Makefile
-+++ apt-0.7.14/Makefile
-@@ -15,11 +15,11 @@ all headers library clean veryclean bina
- $(MAKE) -C apt-inst $@
- $(MAKE) -C methods $@
- $(MAKE) -C cmdline $@
- $(MAKE) -C ftparchive $@
- $(MAKE) -C dselect $@
-- $(MAKE) -C doc $@
-+# $(MAKE) -C doc $@
- $(MAKE) -C po $@
-
- # Some very common aliases
- .PHONY: maintainer-clean dist-clean distclean pristine sanity
- maintainer-clean dist-clean distclean pristine sanity: veryclean
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/remove-redeclaration.patch b/meta/recipes-devtools/apt/apt-0.7.14/remove-redeclaration.patch
deleted file mode 100644
index 8d7c891545..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/remove-redeclaration.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Fix build errors on gcc 4.7:
-
-deb/deblistparser.cc: In member function 'virtual short unsigned int debListParser::VersionHash()':
-deb/deblistparser.cc:212:13: error: redeclaration of 'char* I'
-deb/deblistparser.cc:202:22: error: 'const char** I' previously declared here
-
-Upstream-Status: Backport
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- apt-pkg/deb/deblistparser.cc | 10 +++++-----
- cmdline/apt-get.cc | 8 ++++----
- 2 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/apt-pkg/deb/deblistparser.cc b/apt-pkg/deb/deblistparser.cc
---- a/apt-pkg/deb/deblistparser.cc
-+++ b/apt-pkg/deb/deblistparser.cc
-@@ -209,18 +209,18 @@ unsigned short debListParser::VersionHash()
- /* Strip out any spaces from the text, this undoes dpkgs reformatting
- of certain fields. dpkg also has the rather interesting notion of
- reformatting depends operators < -> <= */
-- char *I = S;
-+ char *J = S;
- for (; Start != End; Start++)
- {
- if (isspace(*Start) == 0)
-- *I++ = tolower(*Start);
-+ *J++ = tolower(*Start);
- if (*Start == '<' && Start[1] != '<' && Start[1] != '=')
-- *I++ = '=';
-+ *J++ = '=';
- if (*Start == '>' && Start[1] != '>' && Start[1] != '=')
-- *I++ = '=';
-+ *J++ = '=';
- }
-
-- Result = AddCRC16(Result,S,I - S);
-+ Result = AddCRC16(Result,S,J - S);
- }
-
- return Result;
-diff --git a/cmdline/apt-get.cc b/cmdline/apt-get.cc
---- a/cmdline/apt-get.cc
-+++ b/cmdline/apt-get.cc
-@@ -1752,12 +1752,12 @@ bool DoInstall(CommandLine &CmdL)
- if ((*Cache)[I].Install() == false)
- continue;
-
-- const char **J;
-- for (J = CmdL.FileList + 1; *J != 0; J++)
-- if (strcmp(*J,I.Name()) == 0)
-+ const char **K;
-+ for (K = CmdL.FileList + 1; *K != 0; K++)
-+ if (strcmp(*K,I.Name()) == 0)
- break;
-
-- if (*J == 0) {
-+ if (*K == 0) {
- List += string(I.Name()) + " ";
- VersionsList += string(Cache[I].CandVersion) + "\n";
- }
---
-1.7.1
-
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/truncate-filename.patch b/meta/recipes-devtools/apt/apt-0.7.14/truncate-filename.patch
deleted file mode 100644
index db1c42b66c..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/truncate-filename.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-strutl.cc: the filename can't be longer than 255
-
-The URItoFileName translates the path into the filename, but the
-filename can't be longer than 255 according to
-/usr/include/linux/limits.h.
-
-Truncate it when it is longer than 240 (leave some spaces for
-".Packages" and "._Release" suffix)
-
-Upstream-Status: Pending
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- apt-pkg/contrib/strutl.cc | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/apt-pkg/contrib/strutl.cc b/apt-pkg/contrib/strutl.cc
---- a/apt-pkg/contrib/strutl.cc
-+++ b/apt-pkg/contrib/strutl.cc
-@@ -399,7 +399,12 @@ string URItoFileName(const string &URI)
- // "\x00-\x20{}|\\\\^\\[\\]<>\"\x7F-\xFF";
- string NewURI = QuoteString(U,"\\|{}[]<>\"^~_=!@#$%^&*");
- replace(NewURI.begin(),NewURI.end(),'/','_');
-- return NewURI;
-+
-+ // Truncate from the head when it is longer than 240
-+ if(NewURI.length() > 240)
-+ return NewURI.substr(NewURI.length() - 240, NewURI.length() - 1);
-+ else
-+ return NewURI;
- }
- /*}}}*/
- // Base64Encode - Base64 Encoding routine for short strings /*{{{*/
---
-1.7.10.4
-
diff --git a/meta/recipes-devtools/apt/apt-0.7.14/use-host.patch b/meta/recipes-devtools/apt/apt-0.7.14/use-host.patch
deleted file mode 100644
index 485ad7ba37..0000000000
--- a/meta/recipes-devtools/apt/apt-0.7.14/use-host.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
----
- buildlib/sizetable | 4 +++-
- configure.in | 2 +-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-Index: apt-0.7.14/buildlib/sizetable
-===================================================================
---- apt-0.7.14.orig/buildlib/sizetable
-+++ apt-0.7.14/buildlib/sizetable
-@@ -11,6 +11,9 @@
- # The format is:-
- # CPU endian sizeof: char, int, short, long
- i386 little 1 4 2 4
-+i486 little 1 4 2 4
-+i586 little 1 4 2 4
-+i686 little 1 4 2 4
- armeb big 1 4 2 4
- arm little 1 4 2 4
- alpha little 1 4 2 8
-@@ -21,4 +24,5 @@ m68k big 1 4 2 4
- powerpc big 1 4 2 4
- mips big 1 4 2 4
- hppa big 1 4 2 4
--m32r big 1 4 2 4
-\ No newline at end of file
-+m32r big 1 4 2 4
-+x86_64 little 1 4 2 8
-Index: apt-0.7.14/configure.in
-===================================================================
---- apt-0.7.14.orig/configure.in
-+++ apt-0.7.14/configure.in
-@@ -88,7 +88,7 @@ dnl This is often the dpkg architecture
- dnl First check against the full canonical canoncial-system-type in $target
- dnl and if that fails, just look for the cpu
- AC_MSG_CHECKING(debian architecture)
--archset="`dpkg-architecture -qDEB_HOST_ARCH`"
-+archset="`echo $host_alias|cut -d'-' -f1`"
- if test "x$archset" = "x"; then
- AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
- fi