aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glibc/glibc-testing.inc2
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-nfs.bb6
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-core/glibc/glibc-testing.inc b/meta/recipes-core/glibc/glibc-testing.inc
index fd1af39922..a9bbf37a17 100644
--- a/meta/recipes-core/glibc/glibc-testing.inc
+++ b/meta/recipes-core/glibc/glibc-testing.inc
@@ -54,7 +54,7 @@ then
echo "1. You dont have passwordless ssh setup to access \$target"
echo "2. NFS share on \$target is not mounted or if mounted then not matching the build tree layout."
echo " The tree should be accessible at same location on build host and target"
- echo " You can add nfs-server to IMAGE_FEATURES to get the nfs client on target"
+ echo " You can add nfs-client to IMAGE_FEATURES to get the nfs client on target"
echo "3. nfs server on build host is not running."
echo " Please make sure that you have 'no_root_squash' added in /etc/exports if you want"
echo " to test as root user on target (usually its recommended to create a non"
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb b/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
index 247a30e063..1882d3ad16 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-nfs.bb
@@ -8,7 +8,11 @@ PR = "r2"
inherit packagegroup
-PACKAGES = "${PN}-server"
+PROVIDES = "${PACKAGES}"
+PACKAGES = "${PN}-server ${PN}-client"
+
+SUMMARY_${PN}-client = "NFS client"
+RDEPENDS_${PN}-client = "nfs-utils-client"
SUMMARY_${PN}-server = "NFS server"
RDEPENDS_${PN}-server = "\