aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux/configure-sbindir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux/configure-sbindir.patch')
-rw-r--r--meta/recipes-core/util-linux/util-linux/configure-sbindir.patch15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta/recipes-core/util-linux/util-linux/configure-sbindir.patch b/meta/recipes-core/util-linux/util-linux/configure-sbindir.patch
index f1f5ef4e4f..a5b1ff12e5 100644
--- a/meta/recipes-core/util-linux/util-linux/configure-sbindir.patch
+++ b/meta/recipes-core/util-linux/util-linux/configure-sbindir.patch
@@ -1,18 +1,23 @@
util-linux: take ${sbindir} from the environment if it is set there
+fix the test, the [ ] syntax was getting eaten by autoconf
Signed-off-by: Phil Blundell <pb@pbcl.net>
+Signed-off-by: Saul Wold <sgw@linux.intel.com
Upstream-Status: Inappropriate [configuration]
---- util-linux-2.21.2/configure.ac~ 2012-09-22 09:29:12.354215377 +0100
-+++ util-linux-2.21.2/configure.ac 2012-09-22 16:47:14.713628946 +0100
-@@ -67,7 +67,9 @@
+Index: util-linux-2.22.1/configure.ac
+===================================================================
+--- util-linux-2.22.1.orig/configure.ac
++++ util-linux-2.22.1/configure.ac
+@@ -73,7 +73,10 @@ AC_SUBST([localstatedir])
usrbin_execdir='${exec_prefix}/bin'
AC_SUBST([usrbin_execdir])
-usrsbin_execdir='${exec_prefix}/sbin'
-+if [ -z "$usrsbin_execdir" ]; then
++if test -z "$usrsbin_execdir" ;
++then
+ usrsbin_execdir='${exec_prefix}/sbin'
+fi
AC_SUBST([usrsbin_execdir])
- usrlib_execdir='${exec_prefix}/'$libdirname
+ case $libdir in