aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tinylogin/tinylogin-1.4
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tinylogin/tinylogin-1.4')
-rw-r--r--meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch b/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch
new file mode 100644
index 0000000000..dc5bc3f123
--- /dev/null
+++ b/meta/recipes-core/tinylogin/tinylogin-1.4/use_O2_option.patch
@@ -0,0 +1,19 @@
+tinylogin will meet segment fault if compiled by gcc-4.5.0 when enable both
+frename-registers and Os options. Use O2 instead.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN tinylogin-1.4-orig/Makefile tinylogin-1.4/Makefile
+--- tinylogin-1.4-orig/Makefile 2010-09-16 13:02:06.302192295 +0800
++++ tinylogin-1.4/Makefile 2010-09-16 13:02:34.634167846 +0800
+@@ -97,9 +97,7 @@
+ #--------------------------------------------------------
+
+
+-# use '-Os' optimization if available, else use -O2
+-OPTIMIZATION = $(shell if $(CC) -Os -S -o /dev/null -xc /dev/null >/dev/null 2>&1; \
+- then echo "-Os"; else echo "-O2" ; fi)
++OPTIMIZATION = -O2
+
+ WARNINGS = -Wall
+