aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_232.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd_232.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_232.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd_232.bb b/meta/recipes-core/systemd/systemd_232.bb
index 3391c0118b..5b45eb221a 100644
--- a/meta/recipes-core/systemd/systemd_232.bb
+++ b/meta/recipes-core/systemd/systemd_232.bb
@@ -273,7 +273,7 @@ do_install_ptest () {
}
python populate_packages_prepend (){
- systemdlibdir = d.getVar("rootlibdir", True)
+ systemdlibdir = d.getVar("rootlibdir")
do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)
}
PACKAGES_DYNAMIC += "^lib(udev|systemd|nss).*"
@@ -591,6 +591,6 @@ python () {
raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
import re
- if re.match('.*musl*', d.getVar('TARGET_OS', True)) != None:
+ if re.match('.*musl*', d.getVar('TARGET_OS')) != None:
raise bb.parse.SkipPackage("Not _yet_ supported on musl based targets")
}