aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-base.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index f151591f18..217830801d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -114,6 +114,15 @@ python __anonymous () {
if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features):
d.setVar("ADD_3G", "packagegroup-base-3g")
+
+ # For backwards compatibility after rename
+ packages = d.getVar("PACKAGES", True).split()
+ packages.remove("packagegroup-distro-base")
+ packages.remove("packagegroup-machine-base")
+ for pkg in packages:
+ d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-base", "task-base"))
+ d.appendVar("RPROVIDES_packagegroup-distro-base", "task-distro-base")
+ d.appendVar("RPROVIDES_packagegroup-machine-base", "task-machine-base")
}
#